Error to load my page


#1

Dear support,

I’m trying to load my page (ricshark01.gear.host) and I see this error: “You do not have permission to view this directory or page” that is displayed in the browser. Could you help me, please?


#2

This appears to be resolved. Could you post your solution?


#3

No, it’s not resolved, but I really don’t know what I need to do. I just upload all my files into your wwwroot folder, but it didn’t work. It’s a Asp.net core 2. (ricshark01.gear.host)

If you check ricshark.gear.host that is Asp.net, you’ll see that it works and I also upload all my files into your wwwroot folder.

I’m not sure if I need to follow a different process if the site is Asp.net core 2.

Both sites work fine when they are locally.

Thanks,

Best Regards,

Ricardo


#4

Did you follow the instructions located here: https://www.gearhost.com/documentation/deploy-net-core-application

That doc says you must edit you .csproj file and add the RuntimeIdentifiers tag above the TargetFramework.

Let me know if you’ve read those instructions and followed them.


#5


Here is a shot from my csproj file for an ASP.NET Core 2.0 app I have up and running on gear host. Hope it helps!


#6

Thanks for your help. I just updated like yours, but it still does not work. I’m not sure if I send all files to wwwroot or some files to site folder and the wwwroot (from my local) to wwwroot (remote). Could you help me, please?


#7

All of your cs and html pages need to live under the wwwroot folder. And then they also need to be in the correct subfolders depending on what type of app you are deploying.

I’ve read on a different thread that you need to compile an ASP.NET Core app as a self-contained application: ASP Core application trying to read directory


#8

Hey Abraham,

You were right! I tried and it worked fine now. Further more I learned how to deploy through Visual Studio and it made my work easier.

Thank you!

Ricardo