ASP.NET 5 Core support for MVC 6?

Hi!

I need to host an MVC 6 (ASP.NET 5 / core) app.

Is it supported? How do i deploy my app?

I already tried to deploy with web matrix deploy file provided and i got 401 ERROR_USER_UNAUTHORIZED

Thanks for your help

2 Likes

Hey @polkien we’ll be releasing it as soon as Microsoft goes live. Until then we’ll be offering the ability to run RC1 hopefully in a couple of weeks!

Is asp.net core enabled already? I can’t find any mention of it?

It’s not available just yet but we are working on it.

Hi,

It’s been a while since .Net Core goes live. Other providers support it already. But I still love the services from GearHost. Any luck that we’ll have it?

Any updates on this? ASP.NET Core is already released for a while now.

1 Like

Any update on ASP.Net Core support?

Yes I need to run an ASP.NET Core app and would love to continue using GearHost.

1 Like

I would love having ASP.Net Core support.

For everyone interested here you can run ASP.NET Core applications on Gear Host without issue. You just have to be sure to compile & publish things properly. I’ve been doing it for a while now and am seeing no issues.

I blogged about the process here: http://mitchelsellers.com/blogs/2017/04/27/publishing-aspnet-core-applications-to-azure-action-pack-hosting.aspx

One thing to keep in mind is that you do have to stop the site to do a full deploy. So my CI Process when deploying to my test sites issues an API Call to stop the site and then another to start it after the file copy is done.

Hi there! I think I’m summoning an old issue but I really couldn’t manage to do a successful deploy. Actually I already tried to do in this blog post http://talk.gearhost.com/clicks/track?url=http%3A%2F%2Fmitchelsellers.com%2Fblogs%2F2017%2F04%2F27%2Fpublishing-aspnet-core-applications-to-azure-action-pack-hosting.aspx&post_id=579&topic_id=138 but no luck. I’m feeling a bit stupid with myself. Anyway @msellers has mentioned in the last sentences of the above post. I will also try that too. Thanks in advance.

And lastly, I wanted to tell here what I’m doing and maybe someone could help me. First of all I made a change to “project.json” file about runtimes like this

“runtimes”: {
“win10-x64”: {}
},

Then I use normal way of publishing a project. I tried every option but I just could manage to connect via ftp using ftp credentials from gearhost configuration. And I always get the same error which is

HTTP Error 502.5 - Process Failure

Common causes of this issue:

The application process failed to start
The application process started but then stopped
The application process started but failed to listen on the configured port

Hope someone can help me.

I had that same problem @emrekayikcilar at one point, are you sure that you have runtimes set for all of your projects? Also, in the call to dotnet publish do you pass the runtime explictly?